Skip to main content
Version: 4.4

Technical Requirements

All recommended versions are based on the latest released version of each series.

Requirements for Supported Software

Requirements for Joomla! 4.x

SoftwareRecommendedMinimum1More Information
PHP8.27.2.5https://www.php.net
Supported Databases
MySQL8.0 +5.6https://www.mysql.com
PostgreSQL11.0 +11.0https://www.postgresql.org/
(ext/pgsql support in PHP has been removed. Now uses the PostgreSQL PDO Driver)
Supported Web Servers
Apache22.4 +2.4https://www.apache.org
(with mod_mysql, mod_xml, and mod_zlib)
Nginx1.18 +1.10https://www.nginx.com/resources/wiki/
Microsoft IIS 310 +8https://www.iis.net

Requirements for Unsupported Software

Requirements for Joomla! 3.x

End of Life

Support for this version of Joomla! ended on 31 December 2014

SoftwareRecommendedMinimumMore Information
PHP48.05.3.10https://www.php.net
(Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, MB Language = Default)
Supported Databases
MySQL55.5.3 +5.1https://www.mysql.com
(InnoDB support required)
SQL Server10.50.1600.1 +10.50.1600.1https://www.microsoft.com/sql
PostgreSQL9.1 +8.3.18https://www.postgresql.org/
(ext/pgsql support in PHP has been removed. Now uses the PostgreSQL PDO Driver)
Supported Web Servers
Apache22.4 +2.0https://www.apache.org
(with mod_mysql, mod_xml, and mod_zlib)
Nginx1.8 +1.0https://www.nginx.com/resources/wiki/
Microsoft IIS 377https://www.iis.net

Please see https://docs.joomla.org/Joomla_Browser_Support for a list of browsers supported in Joomla 3.x.

Requirements for Joomla! 1.6, 1.7, & 2.5

End of Life

Support for this version of Joomla! ended on 31 December 2014

SoftwareRecommendedMinimumMore Information
PHP5.65.2.4https://www.php.net
Supported Databases
MySQL5.0.4 +5.0.4https://www.mysql.com
SQL Server610.50.1600.1 +10.50.1600.1https://www.microsoft.com/sql
Supported Web Servers
Apache22.2 +2.0https://www.apache.org
(with mod_mysql, mod_xml, and mod_zlib)
Nginx1.1 +1.0https://www.nginx.com/resources/wiki/
Microsoft IIS 377https://www.iis.net

Requirements for Joomla! 1.5

End of Life

Support for this version of Joomla! ended on 31 December 2012

SoftwareRecommendedMinimumMore Information
PHP75.34.3.10https://www.php.net
Supported Databases
MySQL4.1 +3.23https://www.mysql.com
Supported Web Servers
Apache22.0 +1.3https://www.apache.org
(with mod_mysql, mod_xml, and mod_zlib)
Microsoft IIS 377https://www.iis.net

Requirements for Joomla! 1.0

End of Life

Support for this version of Joomla! ended on 22 July 2009

SoftwareRecommendedMinimumMore Information
PHP5.34.3.10https://www.php.net
Supported Databases
MySQL4.1 +3.23https://www.mysql.com
Supported Web Servers
Apache22.0 +1.3https://www.apache.org
(with mod_mysql, mod_xml, and mod_zlib)
Microsoft IIS 376https://www.iis.net

Footnotes

Footnotes

  1. This is the minimum version which is guaranteed to work, older versions may work but are not supported.

  2. In order to use SEO URLs, you will need to have the Apache mod_rewrite extension installed. 2 3 4 5

  3. For Microsoft IIS (depending on your setup) you may need the following: PHP, MySQL, Micorosoft URL Rewrite Module, FastCGI

    2 3 4 5
  4. PHP 5.3.1 is required for versions 3.0 through 3.2. At 3.3, the minimum is raised to PHP 5.3.10. Joomla! versions 3.5 and later are compatible with PHP 7.

  5. As of Joomla! 3.5, support for MySQL's utf8mb4 character set is added and used by default by servers which support it.

  6. Support for Microsoft SQL Server was added for the 2.5 release; 1.6 and 1.7 do not have this support.

  7. Do not use PHP 4.3.9, 4.4.2 or 5.0.4. These releases have known bugs that will interfere with installation. Zend Optimizer 2.5.10 for PHP 4.4 also has serious bugs and you should ask your host to upgrade to a newer version. Joomla! versions 1.5.15 and later are compatible with PHP 5.3. Note that the OpenID library is not compatible with PHP 5.3.